My 2016 Scion iA idles rough when ...... - Page 2 - Scion IA Forum
Reply
 
Thread Tools
post #11 of 14 (permalink) Old 03-23-2018, 07:39 PM
Junior Member
 
Cooter's Avatar
 
Join Date: Nov 2017
Posts: 4
I was having a rough idle as well. Plugged my obd2 reader in and reset all the sensors and whatnot and after the ECU relearned O2 sensor, fuel trim etc it idles like new. It's not rough or shaky.
Cooter is offline  
Sponsored Links
Advertisement
 
post #12 of 14 (permalink) Old 03-30-2018, 11:46 PM
Senior Member
 
Join Date: Aug 2016
Posts: 347
What did you disconnect the battery for 5 mins and reconnect
bluelinelife is offline  
post #13 of 14 (permalink) Old 04-05-2019, 02:04 PM
Junior Member
 
Join Date: Mar 2019
Posts: 11
Disconnect the battery for 10 mins or so reconnect it go for a long drive on the freeway 30 mins+ then when you get off the freeway do some city driving and keep it in drive at all the lights it will vibrate for a second at the first couple lights then it stops completely this fixed the problem for me.
Cole is online now  
 
post #14 of 14 (permalink) Old Today, 02:46 PM
Junior Member
 
Join Date: Mar 2019
Posts: 11
My vibration came back the harmonic balancer looks fine motor/tranny mounts look fine air filters are new and theres no stored codes but I've come to find out that it's normal for 4 cylinder engines to vibrate at low rpm so I'm not going to worry about it unless it gets worse or a code pops up.
Cole is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Scion IA Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome