Scion IA Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Anyone else having issues with the cruise control? Mine is always kicking off on the highway. At first I thought it was just sensitivity to bumps but now it kicks off all the time. I'll hit resume, then it's on, then it's off. Drives me nuts and is so bad I can't really use it as it's almost a hazard causing car to slow down at inoportune times. Maybe the AC has something to do with the increased frequency as engine is under more load than in the Spring when I got the car. I'll mention it to dealer when I bring car in for first 6 month service in a couple months but I'm wondering if it's a design issue or if something wrong with my car.
 

·
Registered
Joined
·
204 Posts
I've only used the cruise control a few times (only on very long trips) but it seems that it'll hold at lower speeds but above 80 it was wanting to let the car slow down under the speed I set it at (like I set it at 85 and the car dropped to 80 and stayed there) but I didn't have it completely shut off on me at all, and my a/c hasn't been shut off much since I got the car.
 

·
Registered
Joined
·
204 Posts
Yeah, I don't really use it, mine's the 6 speed so cruise control is kinda pointless anyways... if it were automatic though that'd be a different story, I find that automatics just accelerate on their own when you try to maintain speed.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #8
After 4 service trips, a week and a half with a loaner car, replacement of steering wheel cruise control switch, brake pedal switch, and ECM, cruise control is still not working. Now dealer going to set up visit with Toyota engineer and put me in another loaner. Service advisor mentioned might end up giving me a new replacement car. Bizarre that this is so difficult to fix.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #11
I would assume it would be replaced with a Yaris iA if they end up going that route as they've already transitioned to those. Saw one in the lot. My car has 5100 miles. Purchased last April.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #12
Finally got my car back after 48 total days in a loaner car, 5 trips to the dealer and a whole lot of parts replaced. Cruise worked while on highway and hopefully it continues. It turns out there was a bad ground in a connector pin somewhere. Before finding that out they replaced the steering wheel cruise control switch, the brake switch, the engine ECM, and the complete engine wiring harness. He said they replaced most parts multiple times, put in 3 different ECM's and checked wiring etc repeatedly. They were in contact with Mazda and engineering and spent 45-50 man hours. Said engine wiring harness alone was oveer $3k. All this under warranty and no cost to me as car was only 4 months old when I dropped off with cruise control problem. After the five drop off's they finally just gave me loaner (2017 Camry) and said they would just keep until they fixed it. So they actually treated me well. I had nice car to drive but man what an ordeal for them. I sure hope it's fixed now. I imagine if it fails again they will either offer me buyback or I will pursue as it qualifies for lemon law at this point.
 

·
Registered
Joined
·
347 Posts
I'm glad your dealer has good customer service. I'm really think in about going back to Acura just because the customer service is awesome and the service prices are almost the same as honda. My toyota dealer are __________ fill in whatever the fullest language you can think of lol
 
1 - 13 of 13 Posts
Top