Scion IA Forum banner

1 - 20 of 49 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
I love my iA's display/screen, but is there anyway to mod it? Does anyone know if someone's made a hack to change the colors, display, add other features, or add navigation without paying the $419?

Also my screen kind of freezes sometimes, is there any update to the software that anyone knows of?

Thanks!
 

·
Registered
Joined
·
330 Posts
I love my iA's display/screen, but is there anyway to mod it? Does anyone know if someone's made a hack to change the colors, display, add other features, or add navigation without paying the $419?

Also my screen kind of freezes sometimes, is there any update to the software that anyone knows of?

Thanks!
Search "mazdacmuhacks" because the piece of **** forum moderators block all links i post and never approves it.

you should really search the forum. Navigation has been added to other MZD connect display for free but our uses a different map provider called "HERE" and we would need to get the HERE MAP SD FiLE + the CID for the vehicle use so we can minic it with our vehicle.

get on the mazda3revolution lots of info there too.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
Search "mazdacmuhacks" because the piece of **** forum moderators block all links i post and never approves it.

you should really search the forum. Navigation has been added to other MZD connect display for free but our uses a different map provider called "HERE" and we would need to get the HERE MAP SD FiLE + the CID for the vehicle use so we can minic it with our vehicle.

get on the mazda3revolution lots of info there too.
Sweet. Thank you so much. I will do some research on those two forums. So I'm guessing all of the 3's downloads should work on the iA?
 

·
Registered
Joined
·
330 Posts
Sweet. Thank you so much. I will do some research on those two forums. So I'm guessing all of the 3's downloads should work on the iA?
Majority of everything works. The main ones I use are video player, status bar with digital speed indicator, remove that stupid warning during bootup, and backup camera warning, and touch screen while driving.

Two applications that didn't work: the GPS file I tried but it keeps failing most likely due to different map providers and the speedometer app didn't work.

One application that not sure of is the android auto. It seems to work with other people but it didn't like my LG G2.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
Majority of everything works. The main ones I use are video player, status bar with digital speed indicator, remove that stupid warning during bootup, and backup camera warning, and touch screen while driving.

Two applications that didn't work: the GPS file I tried but it keeps failing most likely due to different map providers and the speedometer app didn't work.

One application that not sure of is the android auto. It seems to work with other people but it didn't like my LG G2.
Wow, I just took a look through it and it looks great. I can't wait to play with it and see what works. So the speedometer app doesn't work for yours? That was what got me the most excited. I will see if it works but expect it not to.
 

·
Registered
Joined
·
330 Posts
Wow, I just took a look through it and it looks great. I can't wait to play with it and see what works. So the speedometer app doesn't work for yours? That was what got me the most excited. I will see if it works but expect it not to.
Yeah not sure, I haven't tried the last update version from digi yet but for some reason the speed report is fine for the status bar.

Let me know if you figure it out. I wasn't patient enough to dig into the codes but majority of the output works fine. From what I recall the GPS speed does update thus we just need to get the speedometer to map the GPS speed. It's probably a pretty easy fix to be honest.
 

Attachments

·
Registered
Joined
·
39 Posts
Discussion Starter #9
Yeah not sure, I haven't tried the last update version from digi yet but for some reason the speed report is fine for the status bar.

Let me know if you figure it out. I wasn't patient enough to dig into the codes but majority of the output works fine. From what I recall the GPS speed does update thus we just need to get the speedometer to map the GPS speed. It's probably a pretty easy fix to be honest.

Hmm. I'm no good at codes but I might downgrade to .753 so I can try it on mine. (It doesn't allow .760, which is of course what I just spent an hour upgrading to).

I will play around more later and come back with what I have. Thanks a lot!
 

·
Registered
Joined
·
330 Posts
Hmm. I'm no good at codes but I might downgrade to .753 so I can try it on mine. (It doesn't allow .760, which is of course what I just spent an hour upgrading to).

I will play around more later and come back with what I have. Thanks a lot!
Wait... how did you upgrade to .760? The scion system is different. I consider just changing my entire software to Mazda 3 so we can get the free GPS and speedometer to work for sure... Maybe you seem more risk taking perhaps you can try that path :)
 

·
Registered
Joined
·
39 Posts
Discussion Starter #11
Wait... how did you upgrade to .760? The scion system is different. I consider just changing my entire software to Mazda 3 so we can get the free GPS and speedometer to work for sure... Maybe you seem more risk taking perhaps you can try that path :)
Right here http://mazdacmuhacks.com/?page_id=13

So I updated to 55.00.760A, then to .753 because the instructions make it seem like it works better with the older for some reason.

However, none of the mods are working when I try them, and I follow the instructions to a T.

How did you do yours?
 

·
Registered
Joined
·
330 Posts
Right here http://mazdacmuhacks.com/?page_id=13

So I updated to 55.00.760A, then to .753 because the instructions make it seem like it works better with the older for some reason.

However, none of the mods are working when I try them, and I follow the instructions to a T.

How did you do yours?
Try searching for all in one tweak. I can't post the freaking link cause of the moderator hates me. I get that b.s. below but the all in tweak seems to work smoothly than all those individual tweaks. The all in one you can hand select stuff as well.

latest version is 1.46 i just used to change my background and it worked just fine.
 

Attachments

·
Registered
Joined
·
330 Posts
Hmm. I'm no good at codes but I might downgrade to .753 so I can try it on mine. (It doesn't allow .760, which is of course what I just spent an hour upgrading to).

I will play around more later and come back with what I have. Thanks a lot!
What color is your navigation? Is it red now or still blue?
 

·
Registered
Joined
·
39 Posts
Discussion Starter #15 (Edited)
Okay I will try the all in one. Is it this link? The "Common Tweaks?" http://mazdacmuhacks.com/?page_id=22

And now it is red with a Mazda symbol that comes on. It's cool, but I actually liked how the Scion had the iA graphic that illuminated at startup. But oh well. :D
Okay nevermind I found the AIO tweak. But how do you install it? Mine still isn't popping up when I plug the USB in...


EDIT: Okay I am reading the README file to learn more and am about to edit it to add the tweaks I want to add, then will try it via the instructions and get back to you.
 

·
Registered
Joined
·
330 Posts
Okay nevermind I found the AIO tweak. But how do you install it? Mine still isn't popping up when I plug the USB in...


EDIT: Okay I am reading the README file to learn more and am about to edit it to add the tweaks I want to add, then will try it via the instructions and get back to you.
Hey I owe you for this but I manage to get the navigation to work! from Mazda 3 files. So free navigation i'll do a write up on it later
 

Attachments

·
Registered
Joined
·
330 Posts
Wow, I just took a look through it and it looks great. I can't wait to play with it and see what works. So the speedometer app doesn't work for yours? That was what got me the most excited. I will see if it works but expect it not to.
Hey speedometer works since I got the navigation working just fyi. NOT SURE if it's the navigation or the Mazda universal firmware.
 

Attachments

·
Registered
Joined
·
330 Posts
I used the all on one tweak, did you format the flash drive to fat32? and let it sit in for about a minute. I essentially did what you did flash the new firmware and install the tweaks
 

·
Registered
Joined
·
39 Posts
Discussion Starter #20
I used the all on one tweak, did you format the flash drive to fat32? and let it sit in for about a minute. I essentially did what you did flash the new firmware and install the tweaks
Are you on .753 or .760?

I am on my laptop (a Chromebook borrowed from my HS) at my internship right now so I can't edit anything on the flash drive until I get home later, and then I will follow the directions on the README file. Could you get a couple pictures of your choose.CMD file and root folder so I can get an idea of what I should be doing?
 
1 - 20 of 49 Posts
Top