Scion IA Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I ordered the nav SD card off of Amazon and it didn't work, so I had a replacement sent and that one doesn't seem to be working either. The videos I saw online was just putting the card in and it automatically unlocked, but my car doesn't respond at all. Am I doing something wrong? Has there been an update? Could I have gotten 2 bad cards? The way they were packaged made it seem like 2 different sellers fulfilled the orders.
 

·
Registered
Joined
·
23 Posts
I am trying to get navigation for my 2019 LE, my Toyota dealer says the SD card is not available, as in nonexistant, no such thing exists, or ever has existed.

so I bought a card for a 2019 mazda3 from ebay.
inserted it as instructed with the car running, the display changed to say it was installing navigation, so I plugged it in right.
after a moment the display changed to 'invalid card inserted', so I pulled it back out, (push it in a bit and it pops up enough to grab to pull out)

I am interested in seeing how the system responds when I plug in the SD card I use for STL files for my 3D printer.

so.. important installation notes
1 the system wants to be ON when you plug the card in, it MIGHT work if you plug the card in with the car off and THEN turn it on, but it DOES work if the car is running.

2 the card is NOT plugged in if there is enough sticking out to grab and pull.
if you can pull it out, do so, and reinsert it until you cannot pull it out


the program has a vehical identification routine that locks the specific card to a specific car (vin) after it gets driven a few miles, so buying a USED card from ebay might well not work even though it is the correct version card since YOU don't have the right car for that specific card. I would expect an 'invalid card' message on the attempt.
 
1 - 4 of 4 Posts
Top