Scion IA Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,
I got my 2020 toyota yaris le 6 months ago. Everything was fine till last week when I noticed the car is “vibrating/shaking” everytime I stop on red light and press the break, or on reverse. It goes away when the car is parked or when the A/C is running. Everything was fine before, any ideas what’s the reason? It doesn't seem to be happening everytime, usually after I drive for over 20-25minutes..
 

·
Registered
Joined
·
3 Posts
I had the same issue before on my 2017 iA. It happened after I got the engine oil replaced with the 5W-30 engine oil at a Toyota dealer. The vibration issue disappeared after I replaced it again with the Costco Kirkland 0W-20 engine oil. I guess the vibration issue was due to the higher viscosity of the 5W-30 oil used by the Toyota dealer (the owner's manual recommends 0W-20).
 

·
Registered
Joined
·
1 Posts
Hello,
I got my 2020 toyota yaris le 6 months ago. Everything was fine till last week when I noticed the car is “vibrating/shaking” everytime I stop on red light and press the break, or on reverse. It goes away when the car is parked or when the A/C is running. Everything was fine before, any ideas what’s the reason? It doesn't seem to be happening everytime, usually after I drive for over 20-25minutes..
I have the same problem. 2017. I notice it happens more in cold weather and if I’m stopped in drive I can temporarily stop the vibrations by shifting into second then back into first.
 

·
Registered
Scion ia 2016
Joined
·
8 Posts
I had the same issue before on my 2017 iA. It happened after I got the engine oil replaced with the 5W-30 engine oil at a Toyota dealer. The vibration issue disappeared after I replaced it again with the Costco Kirkland 0W-20 engine oil. I guess the vibration issue was due to the higher viscosity of the 5W-30 oil used by the Toyota dealer (the owner's manual recommends 0W-20).
iam having vibration in the motor when the car y cold like i go sleep then wake up at morning and start it happends sometimes random(less than 6 sec), and then all is good...u think it can be this?
 

·
Registered
Joined
·
44 Posts
Vibration with A/C off is your motor mounts. Week part of car. Violent misfire on start up and multi cylinder misfire plus other lights, is carbon in the intakes. Please read more in Misfire thread from me
 
1 - 6 of 6 Posts
Top